スポンサーリンク

ネットワーク【3分】シンキング – IPv6(OSPF)が設定できない

Cisco
カモフラ<br>(管理人)
カモフラ
(管理人)

ネットワーク(特にCisco)が大好きな皆様へCCNA/CCNP/CCIE試験で問われる【お題】を毎回Quiz形式で出題致します。また、本ブログではCiscoさんが無償で提供する【Packet Tracer】や【GNS3】を利用しての簡単なシュミレーションと実際の業務で役立つワンポイントなども織り混ぜながら、皆さんが楽しめるコンテンツ(3分でサクッと読める内容)となります。

本日のお題 :

Router_A<>BではIPv6通信がStatic設定されており、現在Loopbackアドレス<2001::1 <> 2002::1>にて疎通が可能です。ネットワークセグメントが多くなったため、Static接続からIPv6(OSPF)へ設定変更したところ、エラーとなりOSPFの設定ができませんでした。(解決策を答えなさい)

  • A : “ip routing”を有効にする
  • B : “リンクローカルアドレス”を設定する
  • C : “ipv6 unicast-routing”を有効にする
  • D : “リンクグローバルアドレス”を設定する

Router_Aコンフィグ

hostname Router_A
ip cef
no ipv6 cef
no ip domain-lookup
!
interface Loopback1
no ip address
ipv6 address 2001::1/128
!
interface GigabitEthernet0/0
no ip address
duplex auto
speed auto
ipv6 address 2003::1/126
!
ip classless
ipv6 route 2002::1/128 2003::2
!
line con 0
line aux 0
line vty 0 4
login
!
end

Router_Bコンフィグ

hostname Router_B
ip cef
no ipv6 cef
no ip domain-lookup
!
interface Loopback1
no ip address
ipv6 address 2002::1/128
!
interface GigabitEthernet0/0
no ip address
duplex auto
speed auto
ipv6 address 2003::2/126
!
ip classless
ipv6 route 2001::1/128 2003::1
!
line con 0
line aux 0
line vty 0 4
login
!
end

本日の回答 :

正解は【C】となります。

現在の設定にて「Router_A(config)#ipv6 router ospf 1」コマンドを打つと「% IPv6 routing not enabled」と出力され、OSPF設定ができません。この問題を切り分けるために、以下の Cisco Configuration Guide を参照してみると、

Configuring IPv6 Addressing and Enabling IPv6 Routing」の箇所に「ipv6 unicast-routing」コマンドを有効にしなさいとありますので、このコマンド投入後は無事OSPFの設定ができました。

今回のケースは実業務でよくあるミスとなります。その際の切り分けとして、「Cisco Configuration Guide」から設定ミスがないか?を確認することが解決への近道です。まずはシンプルにコンフィグ内容をチェックすることが重要ですね。

おすすめの書籍 :

Cisco人気ブログのご紹介 :

皆様からのご質問について

本サイトでは皆様からご質問を受け付けております。ご質問には必ずご回答させていただきますので、まずは本ブログサイトの”お問い合わせ“より、ご連絡をお願い致します。

Cisco
スポンサーリンク
♡(ˊo̴̶̷̤ ᴗ o̴̶̷̤ˋ)***シェアをお願い致します***(ˊo̴̶̷̤ ᴗ o̴̶̷̤ˋ)♡