スポンサーリンク

ネットワーク【3分】シンキング – OSPFルートが受信できない

Cisco
カモフラ<br>(管理人)
カモフラ
(管理人)

ネットワーク(特にCisco)が大好きな皆様へCCNA/CCNP/CCIE試験で問われる【お題】をQuiz形式で出題致します。また、本ブログではCiscoさんが無償で提供する【Packet Tracer】や【GNS3】を利用しての簡単なシュミレーションと実際の業務で役立つワンポイントなども織り混ぜながら、皆さんが楽しめるコンテンツ(3分でサクッと読める内容)となります。

本日のお題 :

Router_A<>BではOSPFが設定されており、双方でNeighborがはれている状況である。Router_BのバックボーンNWにArea0のサブネットが追加された後、OSPFルートの受信ができなくなりました。(解決策を答えなさい)

  • A : ルータAとBに”Router_ID”を設定する
  • B : Virtual-linkにNeighborの”LBアドレス”を設定する
  • C : ルータAとBに”clear ip ospf process”を実施する
  • D : ルータAとBのGi0/0 I/Fにshutdown/no shutdownを実施する

Router_Aコンフィグ

hostname Router_A
ip cef
no ip domain-lookup

!
interface Loopback1
ip address 1.1.1.1 255.255.255.255
!
interface GigabitEthernet0/0
ip address 192.168.1.1 255.255.255.0
!
interface GigabitEthernet0/1
ip address 192.168.0.1 255.255.255.0
!

router ospf 1
log-adjacency-changes
network 192.168.0.0 0.0.0.255 area 0
network 192.168.1.0 0.0.0.255 area 1
!
line con 0
line aux 0
line vty 0 4
login
!
end

Router_Bコンフィグ

hostname Router_B
ip cef
no ip domain-lookup
!
interface Loopback1
ip address 2.2.2.2 255.255.255.255
!

interface GigabitEthernet0/0
ip address 192.168.1.2 255.255.255.0
!
interface GigabitEthernet0/1
ip address 192.168.2.2 255.255.255.0
!
router ospf 1
log-adjacency-changes
network 192.168.2.0 0.0.0.255 area 0
network 192.168.1.0 0.0.0.255 area 1
!

line con 0
line aux 0
line vty 0 4
login
!
end

本日の回答 :

正解は【B】となります。

現在の設定にて「show ip ospf neighbor」コマンドを打ってもエラーは見つからず、OSPF経由のルートが習得できていません。ネットワーク構成図を細かくチェックすると以下の状況と同じ状態となっています。

「OSPF AS内のすべてのエリアは、バックボーン エリア(エリア0)に物理的に接続されている必要がある」のですが、エリア1を挟んで左右のエリア0と接続してしまっているため、今回のケースでは、Router_A<>Bにて「仮想リンク = virtual-link」を有効にする必要があります。(仮想リンクに設定するアドレスはNeighborのルータID となりますが、明示的にセットしない場合、最も高いIPアドレスか、ループバックアドレスがセットされます。また、ルータID を検索するには、show ip ospf interface コマンドを使用します)

OSPFを設計する場合、今回のようなエリア分けは通常実施しないのですが、企業統合やAS集約など有事の際やエリア設計のミスなどで「仮想リンク = virtual-link」が必要となるケースがございます。見慣れない特殊構成を検討する場合は事前の検証や「Cisco Configuration Guide」からベストプラクティスを事前に確認することがトラブルを抑制するための近道です。

おすすめの書籍 :

Cisco人気ブログのご紹介 :

皆様からのご質問について

本サイトでは皆様からご質問を受け付けております。ご質問には必ずご回答させていただきますので、まずは本ブログサイトの”お問い合わせ“より、ご連絡をお願い致します。

Cisco
スポンサーリンク
♡(ˊo̴̶̷̤ ᴗ o̴̶̷̤ˋ)***シェアをお願い致します***(ˊo̴̶̷̤ ᴗ o̴̶̷̤ˋ)♡