スポンサーリンク

ネットワーク【3分】シンキング – EIGRP NeighborがUPしない

Cisco
カモフラ<br>(管理人)
カモフラ
(管理人)

ネットワーク(特にCisco)が大好きな皆様へCCNA/CCNP/CCIE試験で問われる【お題】をQuiz形式で出題致します。また、本ブログではCiscoさんが無償で提供する【Packet Tracer】や【GNS3】を利用しての簡単なシュミレーションと実際の業務で役立つワンポイントなども織り混ぜながら、皆さんが楽しめるコンテンツ(3分でサクッと読める内容)となります。

本日のお題 :

Router_A<>BではEIGRPが設定されており、双方でNeighborがはれている状況である。Router_A<>Bに認証設定をおこなったところ、EIGRPルートの受信ができなくなりました。(解決策を答えなさい)

  • A : 共通の”key id”を設定する
  • B : 認証モードを”SHA-1″に変更する
  • C : 認証設定を”EIGRPプロセス(AS)”に実施する
  • D : ルータAとBにて”clear ip eigrp neighbors”を実施する

Router_Aコンフィグ

hostname Router_A
no ip domain-lookup
!
key chain CISCO
key 1
key-string cisco1
!

interface Loopback1
ip address 1.1.1.1 255.255.255.0
!
interface GigabitEthernet0/0
ip address 192.168.0.1 255.255.255.0
ip authentication mode eigrp 1 md5
ip authentication key-chain eigrp 1 CISCO
!
router eigrp 1
network 1.1.1.0 0.0.0.255
network 192.168.0.0
!
end

Router_Bコンフィグ

hostname Router_B
no ip domain-lookup
!
key chain CISCO
key 2
key-string cisco1
!
interface Loopback1
ip address 2.2.2.2 255.255.255.0
!
interface GigabitEthernet0/0
ip address 192.168.0.2 255.255.255.0
ip authentication mode eigrp 1 md5
ip authentication key-chain eigrp 1 CISCO
!
router eigrp 1
network 2.2.2.0 0.0.0.255
network 192.168.0.0
!
end

本日の回答 :

正解は【A】となります。

現在の設定にて「show ip eigrp neighbor or interface」コマンドを打ってもエラーは見つからず、EIGRP経由のルートが習得できていません。また、Router_A<>BのコンフィグをDiff(差分)してみるとどうも”key ID“に差分があるようです。

debug eigrp packet」でデバックしてみると「EIGRP: Received packet with MD5 authentication, key id = 2」、「EIGRP: GigabitEthernet0/0 : ignored packet from 192.168.0.2, opcode = HELLO (missing authentication)」とのことで、どうもkey id = 2を使っての認証では ignored packet が発生して通信エラーのようですので、Key IDを双方で同じにしたところ、無事EIGRP Neighborが確立され、EIGRPルートも無事受信することができました。

Cisco Configuration Guide」を参考に設定してみたものの、期待された動作にならないことはよくあります。そのような場合はコンフィグの差分(Diff)を取ることにより、目視で見落としている差分をきちんとチェックすることが大切です。上記のConfiguration Guideでは「キー番号は、設定に関連するすべてのルータで同じ番号にすることを推奨」とありますが、どうも推奨ではなく、同じでないと正常に機能しないようです。ちょっとしたコンフィグ差分の発生で期待された動作にならないことはよくあることです。そのような時は慌てずにデバックコマンドやコンフィグ差分をチェックして問題を切り分けていくことが実践では求められます。

おすすめの書籍 :

Cisco人気ブログのご紹介 :

皆様からのご質問について

本サイトでは皆様からご質問を受け付けております。ご質問には必ずご回答させていただきますので、まずは本ブログサイトの”お問い合わせ“より、ご連絡をお願い致します。

Cisco
スポンサーリンク
♡(ˊo̴̶̷̤ ᴗ o̴̶̷̤ˋ)***シェアをお願い致します***(ˊo̴̶̷̤ ᴗ o̴̶̷̤ˋ)♡