スポンサーリンク

ネットワーク【3分】シンキング – OSPF LSA-Type7ってなに?

Cisco
カモフラ<br>(管理人)
カモフラ
(管理人)

ネットワーク(特にCisco)が大好きな皆様へCCNA/CCNP/CCIE試験で問われる【お題】をQuiz形式で出題致します。また、本ブログではCiscoさんが無償で提供する【Packet Tracer】や【GNS3】を利用しての簡単なシュミレーションと実際の業務で役立つワンポイントなども織り混ぜながら、皆さんが楽しめるコンテンツ(3分でサクッと読める内容)となります。

本日のお題 :

OSPF エリア10 はスタブなネットワーク構成となっています。今回、新しくRouter_Cを増設した際に外部AS(開発NW)とのStatic接続が必要となりました。本要件を満たすために Router_B、Cに設定変更を行ってください。(複数回答)

  • A : “area 10 stub no-summary” を適応する
  • B : “area 10 nssa no-summary” を適応する
  • C : “area 10 stub” を適応する
  • D : “area 10 nssa” を適応する

Router_B コンフィグ

hostname Router_B
!
interface Loopback1
ip address 2.2.2.2 255.255.255.255
!
interface GigabitEthernet0/0
ip address 192.168.0.2 255.255.255.0
!
interface GigabitEthernet0/1
ip address 192.168.10.1 255.255.255.0
!

router ospf 1
log-adjacency-changes
network 192.168.10.0 0.0.0.255 area 10
network 192.168.0.0 0.0.0.255 area 0
!
line con 0
line aux 0
line vty 0 4
!
end

Router_C コンフィグ

hostname Router_C
!
interface Loopback1
ip address 3.3.3.3 255.255.255.255
!
interface GigabitEthernet0/0
ip address 192.168.10.2 255.255.255.0
!
router ospf 1
log-adjacency-changes
redistribute static metric-type 1 subnets
network 192.168.10.0 0.0.0.255 area 10
!
ip route 172.16.0.0 255.255.0.0 ### 外部NW ###
!

line con 0
line aux 0
line vty 0 4

!
end

本日の回答 :

正解は【B と D】になります。

Not-So-Stubby Area(NSSA)はスタブエリアへ外部ルート(※開発NWへのStatic)の注入が可能です。NSSA エリアへの再配布により、Type 7という特別なリンクステート アドバタイズメント(LSA)が作成されます。また、このType7は、NSSA ABR(Router_B)によってType 5 に変換されます。(すなわち、Router_Aのバックボーンルータでは開発NWへの外部ルートはType5として扱われます)

スタブエリアの弱点は、同じエリアにASBRを配置できないことであり、その改良版が NSSAとなります。将来的な拡張性を確保して、かつ、スタブなエリアを作成する場合はNSSAがとても便利ですが、設定には注意も必要です。【NSSA 内のデフォルトルート問題】NSSA 内にデフォルトルートを設定するには 2 つの方法があり、「NSSA 完全スタブ ルートとして定義する = area xx nssa no-summary」or「area xx nssa default-information-originate」をセットします。ABRにどちらをセットするかはお好みになりますが、「area xx nssa」という設定だけではデフォルトルートがNSSAエリアに生成されず、別エリアのLSA-Type5ルートへの接続ができなくなってしまいますのでご注意が必要です。(詳細は上記のConfiguratinon Guideも参照ください)

おすすめの書籍 :

Cisco人気ブログのご紹介 :

皆様からのご質問について

本サイトでは皆様からご質問を受け付けております。ご質問には必ずご回答させていただきますので、まずは本ブログサイトの”お問い合わせ“より、ご連絡をお願い致します。

Cisco
スポンサーリンク
♡(ˊo̴̶̷̤ ᴗ o̴̶̷̤ˋ)***シェアをお願い致します***(ˊo̴̶̷̤ ᴗ o̴̶̷̤ˋ)♡