スポンサーリンク

ネットワーク【3分】シンキング – 再配布(シードメトリック)ってなに?

Cisco
カモフラ<br>(管理人)
カモフラ
(管理人)

ネットワーク(特にCisco)が大好きな皆様へCCNA/CCNP/CCIE試験で問われる【お題】をQuiz形式で出題致します。また、本ブログではCiscoさんが無償で提供する【Packet Tracer】や【GNS3】を利用しての簡単なシュミレーションと実際の業務で役立つワンポイントなども織り混ぜながら、皆さんが楽しめるコンテンツ(3分でサクッと読める内容)となります。

本日のお題 :

OSPF/EIGRPの検証環境にて、以下のアドレス(1.1.1.1<>3.3.3.3)区間にて疎通NGが発生しています。今回のコンフィグ設定ではOSPF<>EIGRP経由でのルーティングに問題が発生しているので、そのトラブルシューティングを実施してください。(複数回答)

  • A : “シードメトリック” を OSPF/再配布 にセットする
  • B : “default-metric” を OSPF にセットする
  • C : “シードメトリック” を EIGRP/再配布 にセットする
  • D : “default-metric” を EIGRP にセット応する

Router_A コンフィグ

hostname Router_A
!
interface Loopback1
ip address 1.1.1.1 255.255.255.0
!
interface GigabitEthernet0/0
ip address 192.168.1.1 255.255.255.0
!
router ospf 1
log-adjacency-changes
network 1.1.1.0 0.0.0.255 area 0
network 192.168.1.0 0.0.0.255 area 0
!
line con 0
line aux 0
line vty 0 4

!
!
!
!
!
!
end

Router_B コンフィグ

hostname Router_B
!
interface Loopback1
ip address 2.2.2.2 255.255.255.0
!
interface GigabitEthernet0/0
ip address 192.168.1.2 255.255.255.0
!
interface GigabitEthernet0/1
ip address 192.168.2.1 255.255.255.0
!
router eigrp 1
redistribute ospf 1
network 192.168.2.0
!
router ospf 1
log-adjacency-changes
redistribute eigrp 1 subnets
network 192.168.1.0 0.0.0.255 area 0
network 2.2.2.0 0.0.0.255 area 0
!
end

本日の回答 :

正解は【C と D】になります。

OSPF/EIGRPのトラブルシューティングで有効な「show ip ospf/eigrp neighbor, show ip ospf/eigrp interface」でステータス確認してもR1 == OSPF == R2、R2 == EIGRP == R3には特に問題がないので、以下のコンフィグレーションガイドを参考にEIGRP<>OSPFの再配布(redistribution)設定をチェックしてみると、EIGRP設定「redistribute ospf 1」にてシードメトリックがセットされていないので、「redistribute ospf 1 metric 10 100 0 100 1500」または「default-metric 10 100 0 100 1500」を実施することで、OSPFのルートがRouter_Cへ伝達(EIGRP経由)され問題が解決できました。

シードメトリック」って何?と思われた方もいると思いますが、そもそも異なるルーティングプロトコル同士には互換性がありません。そのためルーティングプロトコルに情報を再配布する際にはメトリックを調整してあげる必要がございます。特にご注意は【EIGRP/RIP/ISIS】などへ再配布する際はシードメトリックを必ずセットしないといけません。(デフォルト設定では無限大=無効なルートとして扱われます)

今回のケースではシングル構成の再配布(OSPF<>EIGRP)だったため、ルーティングループの影響はございませんが、本番環境ではNW構成が冗長化されていることがほとんどです。その際には「route-map」や「tag」情報などを使ってルーティングループを抑制する設計も必須となってきます。CCNP試験でもよく出題され、また実践でも再配布/route-map(tag)は必須の知識となりますので、自信のない方は実機検証にて動作確認されることをオススメしたいです。

おすすめの書籍 :

Cisco人気ブログのご紹介 :

皆様からのご質問について

本サイトでは皆様からご質問を受け付けております。ご質問には必ずご回答させていただきますので、まずは本ブログサイトの”お問い合わせ“より、ご連絡をお願い致します。

Cisco
スポンサーリンク
♡(ˊo̴̶̷̤ ᴗ o̴̶̷̤ˋ)***シェアをお願い致します***(ˊo̴̶̷̤ ᴗ o̴̶̷̤ˋ)♡