スポンサーリンク

ネットワーク【3分】シンキング – OSPF(経路集約)について

Cisco
カモフラ<br>(管理人)
カモフラ
(管理人)

ネットワーク(特にCisco)が大好きな皆様へCCNA/CCNP/CCIE試験で問われる【お題】をQuiz形式で出題致します。また、本ブログではCiscoさんが無償で提供する【Packet Tracer】や【GNS3】を利用しての簡単なシュミレーションと実際の業務で役立つワンポイントなども織り混ぜながら、皆さんが楽しめるコンテンツ(3分でサクッと読める内容)となります。

本日のお題 :

リソース消費を軽減する目的でOSPF環境へ経路集約を実施したい。ABR/ASBRで実施するコマンドを選択してください。(複数回答)

  • A : “ip summary-address” をセットする
  • B : “summary-address” をセットする
  • C : “aggregate-address” をセットする
  • D : “area range” をセットする

R1 コンフィグ

hostname R1
!
interface Loopback10
ip address 10.10.10.10 255.255.255.0
!
interface Loopback11
ip address 10.10.11.10 255.255.255.0
!
interface Loopback12
ip address 10.10.12.10 255.255.255.0
!

interface FastEthernet0/0
ip address 192.168.10.1 255.255.255.0

!
router ospf 1
log-adjacency-changes
redistribute static metric-type 1 subnets
network 10.10.10.0 0.0.0.255 area 10
network 10.10.11.0 0.0.0.255 area 10
network 10.10.12.0 0.0.0.255 area 10
network 192.168.10.0 0.0.0.255 area 10
!
ip route 100.0.1.0 255.255.255.0 Null0
ip route 100.0.2.0 255.255.255.0 Null0
ip route 100.0.3.0 255.255.255.0 Null0
!
line con 0
line aux 0
line vty 0 4
!
end

R2 コンフィグ

hostname R2
!
interface FastEthernet0/0
ip address 192.168.10.2 255.255.255.0
!
interface FastEthernet0/1
ip address 192.168.0.2 255.255.255.0
!
router ospf 1
log-adjacency-changes
network 192.168.0.0 0.0.0.255 area 0
network 192.168.10.0 0.0.0.255 area 10
line con 0
line aux 0
line vty 0 4

!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!

end

本日の回答 :

正解は【Bと D】になります。

R3(バックボーン)のルーティングテーブルを確認する限り、「10.10.0.0/16」と「100.0.0.0/16」のルートが経路集約されています。Area(10)での集約はR2(ABR)で「area 10 range 10.10.0.0 255.255.0.0」を行う、外部ルートでの集約はR1(ASBR)にて「summary-address 100.0.0.0 255.255.0.0」を行うで想定通りの経路集約となりました。

実はOSPFデザインで一番センスが問われるのは「経路集約」です。経路集約が行われるポイントは「ABR or ASBR」のどちらかで実施され、本番NWの多くは外部ルート(ASBR)での集約が多い印象です。また、CCNP/CCIE試験での攻略ポイントは、どんなタイプのLSAが経路集約されるのか?をきちんと把握する必要がございます。なかなか机上設計では全体像が把握しづらいので、ぜひ詳細は実機での動作検証がおすすめです。(Stub/NSSAとの組み合わせパターンもぜひ実機がオススメです!)

おすすめの書籍 :

Cisco人気ブログのご紹介 :

皆様からのご質問について

本サイトでは皆様からご質問を受け付けております。ご質問には必ずご回答させていただきますので、まずは本ブログサイトの”お問い合わせ“より、ご連絡をお願い致します。

Cisco
スポンサーリンク
♡(ˊo̴̶̷̤ ᴗ o̴̶̷̤ˋ)***シェアをお願い致します***(ˊo̴̶̷̤ ᴗ o̴̶̷̤ˋ)♡