スポンサーリンク

ネットワーク【3分】シンキング – AAAはシンプルに考えよう!

Cisco
カモフラ<br>(管理人)
カモフラ
(管理人)

ネットワーク(特にCisco)が大好きな皆様へCCNA/CCNP/CCIE試験で問われる【お題】をQuiz形式で出題致します。また、本ブログではCiscoさんが無償で提供する【Packet Tracer】や【GNS3】を利用しての簡単なシュミレーションと実際の業務で役立つワンポイントなども織り混ぜながら、皆さんが楽しめるコンテンツ(3分でサクッと読める内容)となります。

本日のお題 :

以下の条件でリモートアクセスを実施した場合、ログインパスワードとして参照されるコマンドを選択してください。(複数回答)
①Router_AからRouter_B(LB:2.2.2.2)へTelnet
②Router_BからRouter_A(LB:1.1.1.1)へTelnet

  • A : “enable password test”
  • B : “aaa authentication login RADIUS”
  • C : “password TEST”
  • D : “username test password 0 test”

Router_A コンフィグ

hostname Router_A
enable password test
!
aaa new-model
aaa authentication login RADIUS local group radius local
aaa authentication login default local
username test password 0 test
!
interface Loopback1
ip address 1.1.1.1 255.255.255.0
!
interface GigabitEthernet0/0
ip address 192.168.0.1 255.255.255.0
!
router eigrp 1
network 1.1.1.0 0.0.0.255
network 192.168.0.0
!
line con 0
line aux 0
line vty 0 4
password TEST
login authentication default

!
!
end

Router_B コンフィグ

hostname Router_B
enable password test
!
aaa new-model
aaa authentication login RADIUS local group radius local
aaa authentication login default enable
username test password 0 test
!
interface Loopback1
ip address 2.2.2.2 255.255.255.0
!
interface GigabitEthernet0/0
ip address 192.168.0.2 255.255.255.0
!
router eigrp 1
network 2.2.2.0 0.0.0.255
network 192.168.0.0
!
line con 0
line aux 0
line vty 0 4
password TEST
login authentication default
!
end

本日の回答 :

正解は【A と D】になります。

まずはTelnetの認証方式を確認すると”line vty 0 4″に”password TEST“と”login authentication default“の値がセットされています。下記のコンフィグレーションガイドにて確認する限り、”login authentication”がセットされるとline vty 0 4の内容が上書きされ、この内容が優先されるようなので、次に”aaa authentication login default”の設定を確認すると”aaa authentication login default local or enable”とのことなので、ローカル認証の【解答 D】とenable passwordの【解答 A】が正解となります。(実機確認する限り、【解答】通りの認証方式であることが確認できます)

AAA 設定はシンプルですが、とても奥が深いです。特に機器リプレースで古い機種のコンフィグから設定をコンバートすると思わぬトラップ(想定外の動き)にハマる可能性もあるので、認証系の設定は正確な動作=仕様を把握すると共に、不明な内容は事前の実機確認など、安全な対応がオススメです。(リモートから作業する際には特にご注意ください!ミスってDCへダッシュされる方が昨今もとても多いです。ww)

おすすめの書籍 :

Cisco人気ブログのご紹介 :

皆様からのご質問について

本サイトでは皆様からご質問を受け付けております。ご質問には必ずご回答させていただきますので、まずは本ブログサイトの”お問い合わせ“より、ご連絡をお願い致します。

Cisco
スポンサーリンク
♡(ˊo̴̶̷̤ ᴗ o̴̶̷̤ˋ)***シェアをお願い致します***(ˊo̴̶̷̤ ᴗ o̴̶̷̤ˋ)♡