スポンサーリンク

ネットワーク【3分】シンキング – GRE or IPSECのフラグメント対策できてますか?

Cisco
カモフラ<br>(管理人)
カモフラ
(管理人)

ネットワーク(特にCisco)が大好きな皆様へCCNA/CCNP/CCIE試験で問われる【お題】をQuiz形式で出題致します。また、本ブログではCiscoさんが無償で提供する【Packet Tracer】や【GNS3】を利用しての簡単なシュミレーションと実際の業務で役立つワンポイントなども織り混ぜながら、皆さんが楽しめるコンテンツ(3分でサクッと読める内容)となります。

本日のお題 :

新NW移行後、Router_A<>B区間にて “GRE over EIGRP” が導入されました。以下の条件で社内LANからオンラインストレージ(クラウド)へアクセスした際にファイルアクセスがとても遅い事象(頻繁にパケロス)が発生しました。本件の解決策を答えなさい。(解答を1つ選択)

  • A : “ip mtu 1436”
  • B : “ip tcp adjust-mss 1436”
  • C : “ip mtu 1476”
  • D : “ip tcp adjust-mss 1476”

Router_A コンフィグ

hostname Router_A
!
interface Loopback1
ip address 1.1.1.1 255.255.255.0
!
interface Tunnel1
ip address 10.0.0.1 255.255.255.0
tunnel source GigabitEthernet0/0
tunnel destination 192.168.0.2
!
interface GigabitEthernet0/0
ip address 192.168.0.1 255.255.255.0
!
router eigrp 1
network 1.1.1.0 0.0.0.255
network 10.0.0.0 0.0.0.255
!
line con 0
line aux 0
line vty 0 4
!
end

Router_B コンフィグ

hostname Router_B
!
interface Loopback1
ip address 2.2.2.2 255.255.255.0
!
interface Tunnel1
ip address 10.0.0.2 255.255.255.0
tunnel source GigabitEthernet0/0
tunnel destination 192.168.0.1
!
interface GigabitEthernet0/0
ip address 192.168.0.2 255.255.255.0
!
router eigrp 1
network 10.0.0.0 0.0.0.255
network 2.2.2.0 0.0.0.255
!
line con 0
line aux 0
line vty 0 4
!
end

本日の回答 :

正解は【B】になります。

本件ですが、ルーティングには問題がなさそうなので、パケロスの原因はNWのチューニング不足が疑われます。下記のコンフィグレーションガイドを確認する限り、”GRE over EIGRP“の場合、通常のIPパケットに24Byte 余分なGREヘッダーが追加されるため、Router_A<>B区間にてどうも”フラグメント/パケロス“が発生しているようです。(Tunnel I/Fの MTUサイズも1476となっています!)

TCP通信においては、”ip tcp adjust-mss” コマンドで TCPSYN パケットの MSS 値を調整することが可能ですので、MTU=1476に対して、IP/TCPヘッダーの40Byte分を引いた値(1436)をセットしたところ、無事ルータ間にてフラグメントが解消されました。

NW移行後のパフォーマンス問題はよく発生するNWトラブルの1つです。また、GRE/IPSEC/MPLSなどのトンネリング技術においては、IPパケットに付加されるオーバーヘッドを事前に計算しておかないとフラグメントなど、NW全体にパフォーマンス劣化が発生する恐れがあるので特に注意が必要です。

上記ドキュメントも “GRE および IPsec での IP フラグメンテーション” を回避する設計を行うための有益サイトとなりますので、ぜひ深掘りして、IPパケットと仲良くなってもらえたらと思います。

おすすめの書籍 :

Cisco人気ブログのご紹介 :

皆様からのご質問について

本サイトでは皆様からご質問を受け付けております。ご質問には必ずご回答させていただきますので、まずは本ブログサイトの”お問い合わせ“より、ご連絡をお願い致します。

Cisco
スポンサーリンク
♡(ˊo̴̶̷̤ ᴗ o̴̶̷̤ˋ)***シェアをお願い致します***(ˊo̴̶̷̤ ᴗ o̴̶̷̤ˋ)♡