スポンサーリンク

ネットワーク【3分】シンキング – DHCP Relayは簡単ですよね?

Cisco
カモフラ<br>(管理人)
カモフラ
(管理人)

ネットワーク(特にCisco)が大好きな皆様へCCNA/CCNP/CCIE試験で問われる【お題】をQuiz形式で出題致します。また、本ブログではCiscoさんが無償で提供する【Packet Tracer】や【GNS3】を利用しての簡単なシュミレーションと実際の業務で役立つワンポイントなども織り混ぜながら、皆さんが楽しめるコンテンツ(3分でサクッと読める内容)となります。

本日のお題 :

システム変更により、PC1(クライアント端末)は外部セグメントのDHCPサーバからIPアドレスを取得します。”ip helper-address 100.0.0.254″を【Switch_A】のどこに設定するべきでしょうか? 本件の解決策を答えなさい。(解答を1つ選択)

  • A : Interface Gi1/0/1
  • B : Interface Gi1/0/2
  • C : Interface VLAN1
  • D : Interface VLAN2

Switch_A コンフィグ

hostname Switch_A
no spanning-tree vlan 1-2
!
interface Loopback1
ip address 1.1.1.1 255.255.255.0
!
interface GigabitEthernet1/0/1
switchport mode access
switchport nonegotiate
!
interface GigabitEthernet1/0/2
switchport access vlan 2
switchport mode access
switchport nonegotiate
!
interface Vlan1
ip address 192.168.1.1 255.255.255.0
!
interface Vlan2
ip address 192.168.2.1 255.255.255.0
!
router ospf 1
log-adjacency-changes
network 1.1.1.0 0.0.0.255 area 0
network 192.168.1.0 0.0.0.255 area 0
network 192.168.2.0 0.0.0.255 area 0
!
line con 0
line aux 0
line vty 0 4
!
end

Router_A コンフィグ

hostname Router_A
!
interface Loopback1
ip address 2.2.2.2 255.255.255.0
!
interface GigabitEthernet0/0
ip address 192.168.2.2 255.255.255.0
!
interface GigabitEthernet0/1
ip address 100.0.0.1 255.255.255.0
!
router ospf 1
log-adjacency-changes
network 2.2.2.0 0.0.0.255 area 0
network 192.168.2.0 0.0.0.255 area 0
default-information originate
!
ip classless
ip route 0.0.0.0 0.0.0.0 GigabitEthernet0/1
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
!
end

本日の回答 :

正解は【C】になります。

本件ですが、L3SW<>ルータでOSPFを実施しているNW環境のため、DHCPリレーの設定箇所に迷う方もいるかもしれませんが、DHCPリレーはDHCPクライアント(PC1)からの「DHCP DISCOVERを受信する同じブロードキャストドメイン」である必要があります。そのため、Interface Gi1/0/1の設定を確認するとVLAN 1がセットされているため、SVI(Switch Virtual Interface)のInterface Vlan1に対して”ip helper-address”をセットすることにより通信用件が満たされそうです。(ポイントはL3 I/Fにセットする!)

DHCPリレー(ip helper-address)はよくCCNA/CCNPに出題されるトピックの1つです。またテキストを参考に「DHCPリレー設定はクライアントPCと同じセグメントの物理I/Fにセットする」と覚えていると今回のケースでは間違いとなるので、正しい動作について自信のない方は、再度コンフィグレーションガイドで確認がよいかと存じます。DHCPリレーはVRF環境でも同じようにセグメント単位での設定が可能であるが、「ip helper-address vrf name [ global ] address」などVRFの設定を忘れると機能しませんので、ご注意が必要となります。

おすすめの書籍 :

Cisco人気ブログのご紹介 :

皆様からのご質問について

本サイトでは皆様からご質問を受け付けております。ご質問には必ずご回答させていただきますので、まずは本ブログサイトの”お問い合わせ“より、ご連絡をお願い致します。

Cisco
スポンサーリンク
♡(ˊo̴̶̷̤ ᴗ o̴̶̷̤ˋ)***シェアをお願い致します***(ˊo̴̶̷̤ ᴗ o̴̶̷̤ˋ)♡