スポンサーリンク

ネットワーク【3分】シンキング – リモートアクセスができない

Cisco
カモフラ<br>(管理人)
カモフラ
(管理人)

ネットワーク(特にCisco)が大好きな皆様へCCNA/CCNP/CCIE試験で問われる【お題】をQuiz形式で出題致します。また、本ブログではCiscoさんが無償で提供する【Packet Tracer】や【GNS3】を利用しての簡単なシュミレーションと実際の業務で役立つワンポイントなども織り混ぜながら、皆さんが楽しめるコンテンツ(3分でサクッと読める内容)となります。

本日のお題 :

機器リプレースに伴い、新規ルータ(Router_A)に現行ルータのコンフィグを投入したところ、Router_Aに対してリモートアクセス(LB:1.1.1.1へのSSH通信)ができなくなってしまいました。本件の解決策を答えなさい。(解答を1つ選択)

  • A : aaa new-model
  • B : aaa authentication login default enable
  • C : crypto key generate rsa
  • D : enable password/secret

Router_A コンフィグ

hostname Router_A
username TEST password 0 TEST
!
ip ssh version 2
no ip domain-lookup
ip domain-name test.com
!
interface Loopback1
ip address 1.1.1.1 255.255.255.0
!
interface GigabitEthernet0/0
ip address 192.168.1.1 255.255.255.0
!
router eigrp 1
network 192.168.1.0
network 1.1.1.0 0.0.0.255
!
line con 0
line aux 0
line vty 0 4
login local
transport input ssh
!
end

Router_B コンフィグ

hostname Router_B
username TEST password 0 TEST

!
ip ssh version 2
no ip domain-lookup
ip domain-name test.com
!
interface Loopback1
ip address 2.2.2.2 255.255.255.0
!
interface GigabitEthernet0/0
ip address 192.168.1.2 255.255.255.0
!
router eigrp 1
network 192.168.1.0
network 2.2.2.0 0.0.0.255
!
line con 0
line aux 0
line vty 0 4
login local
transport input ssh
!
end

本日の回答 :

正解は【C】になります。

今回のケースではDiff(差分)を取ってもコンフィグ上では、RouterA<>Bに大きな差を見つけることができません。そんな時は初心に戻って、Cisco Configuration Guideをチェックしましょう。SSHを有効にするためには、「hostname -> ip domain-name -> crypto key generate rsa -> ip ssh version」をセットする必要がありそうですが、”show run” にて出力されるコンフィグにはどうも「crypto key generate rsa」は含まれていないようです。また、Router_Aにて”show ip ssh“を実施すると”RSA Key”に対するエラーが発生しているので、このコマンドの再投入で問題が解決できそうです。

既存コンフィグを投入したのにある機能が動作しない」はよくあることです。そのような場合、皆さんはどのようにトラブルシューティングされますか? 一番最初に思いつく、チェック方法は既存コンフィグとの差分(Diff)確認やバグ検索となりますが、コンフィグ投入時のエラーログ確認も問題解決に大きく貢献してくれます。また、今回のケースであれば、コンソールからコンフィグ投入時にエラーが発生するはずなので、分かりやすいですが、シンプルにCisco Configuration Guideをチェックする癖をつけた方が良いと思います。例えば、OSバージョンが上がったことにより機能実装が変わり、追加のコマンドが必要となるケースもありますので、バージョンに依存する機能差分は特に気をつけたい点です。(検証環境が用意できるのであれば、debugコマンドも原因究明がとても早いです) それでも解決できないのであれば、未知の不具合(バグ)も疑われますので、その際は検証ログを添えて、Cisco TACヘケースオープンが解決への近道です。

おすすめの書籍 :

Cisco人気ブログのご紹介 :

皆様からのご質問について

本サイトでは皆様からご質問を受け付けております。ご質問には必ずご回答させていただきますので、まずは本ブログサイトの”お問い合わせ“より、ご連絡をお願い致します。

Cisco
スポンサーリンク
♡(ˊo̴̶̷̤ ᴗ o̴̶̷̤ˋ)***シェアをお願い致します***(ˊo̴̶̷̤ ᴗ o̴̶̷̤ˋ)♡