スポンサーリンク

ネットワーク【3分】シンキング – BGP Transit AS(フィルタ)

Cisco
カモフラ<br>(管理人)
カモフラ
(管理人)

ネットワーク(特にCisco)が大好きな皆様へCCNA/CCNP/CCIE試験で問われる【お題】をQuiz形式で出題致します。また、本ブログではCiscoさんが無償で提供する【Packet Tracer】や【GNS3】を利用しての簡単なシュミレーションと実際の業務で役立つワンポイントなども織り混ぜながら、皆さんが楽しめるコンテンツ(3分でサクッと読める内容)となります。

本日のお題 :

AS20はトランジットASのため、外部AS(AS10<>AS30)から受信したルートのみアドバタイズします。AS20 ルータに最適なトラフィックフィルタを設定しなさい。

ip as-path access-list 1 deny ^$
ip as-path access-list 1 permit .*

  • A : AS20 ルータの”outbound”に filter-list を適応する
  • B : AS20 ルータの”outbound”に route-map を適応する
  • C : AS20 ルータの”outbound”に distribute-list を適応する
  • D : AS20 ルータの”outbound”に prefix-list を適応する

AS10 コンフィグ

hostname AS10
!
interface Loopback1
ip address 10.0.1.1 255.255.255.0
!
interface Loopback2
ip address 10.0.2.1 255.255.255.0
!
interface Loopback3
ip address 10.0.3.1 255.255.255.0
!
interface FastEthernet0/0
ip address 200.1.1.1 255.255.255.252
!
router bgp 10
no synchronization
bgp log-neighbor-changes
network 10.0.1.0 mask 255.255.255.0
network 10.0.2.0 mask 255.255.255.0
network 10.0.3.0 mask 255.255.255.0
neighbor 200.1.1.2 remote-as 20
no auto-summary
!

!
!
!
!
!
end

AS20 コンフィグ

hostname AS20
!
interface Loopback1
ip address 20.0.1.1 255.255.255.0
!
interface Loopback2
ip address 20.0.2.1 255.255.255.0
!
interface Loopback3
ip address 20.0.3.1 255.255.255.0
!
interface FastEthernet0/0
ip address 200.1.1.2 255.255.255.252
!
interface FastEthernet0/1
ip address 201.1.1.2 255.255.255.252
!

router bgp 20
no synchronization
bgp log-neighbor-changes
network 20.0.1.0 mask 255.255.255.0
network 20.0.2.0 mask 255.255.255.0
network 20.0.3.0 mask 255.255.255.0
neighbor 200.1.1.1 remote-as 10
neighbor 201.1.1.1 remote-as 30
no auto-summary
!
end

本日の回答 :

正解は【A】になります。

BGPは正規表現でトラフィックフィルタが可能です。今回のケースでは、AS20はトランジットASなので、内部(AS20)から生成されたルート(20.0.1-3.0/24 )はAS10と30には流さず、それ以外のAS10 or 30経由のルートのみアドバタイスする “neighbor xxx filter-list 1 out” をセットすることで要件通りのルート制御が可能です。

BGPのフィルタには色々と種類があり、一般的には “prefix-list” や “as-path”や”route-map”がよく使われます。特に分かりづらいのが正規表現であり、代表的なルール(_100_ = AS100を含む、^$ = 内部ASで発生、.* = 全てのAS)は最初のうちは丸暗記した方が良いです。BGPマスターのポイントは如何に多くのルート(AS情報)を効率的に管理することができるのか?が重要であり、正規表現やフィルタリング手法は細かくチェックすることが大切です。(CCNP/CCIE攻略にはBGPを極める必要がございます!)

おすすめの書籍 :

Cisco人気ブログのご紹介 :

皆様からのご質問について

本サイトでは皆様からご質問を受け付けております。ご質問には必ずご回答させていただきますので、まずは本ブログサイトの”お問い合わせ“より、ご連絡をお願い致します。

Cisco
スポンサーリンク
♡(ˊo̴̶̷̤ ᴗ o̴̶̷̤ˋ)***シェアをお願い致します***(ˊo̴̶̷̤ ᴗ o̴̶̷̤ˋ)♡