スポンサーリンク

ネットワーク【3分】シンキング – Passive I/Fってなに?

Cisco
カモフラ<br>(管理人)
カモフラ
(管理人)

ネットワーク(特にCisco)が大好きな皆様へCCNA/CCNP/CCIE試験で問われる【お題】をQuiz形式で出題致します。また、本ブログではCiscoさんが無償で提供する【Packet Tracer】や【GNS3】を利用しての簡単なシュミレーションと実際の業務で役立つワンポイントなども織り混ぜながら、皆さんが楽しめるコンテンツ(3分でサクッと読める内容)となります。

本日のお題 :

検証用コンフィグにてEIGRPのテスト環境を構築しました。今回のコンフィグ設定ではEIGRP経由でルート情報が取得できないようなので、そのトラブルシューティングを実施してください。

  • A : “passive-interface” を Gi0/0 に適応する
  • B : “no passive-interface” を Gi0/0 に適応する
  • C : “passive-interface Gi0/0” を EIGRP に適応する
  • D : “no passive-interface Gi0/0” を EIGRP に適応する

Router_A コンフィグ

hostname Router_A
!
interface Loopback1
ip address 1.1.1.1 255.255.255.0
!
interface GigabitEthernet0/0
ip address 192.168.1.1 255.255.255.0
!
router eigrp 1
passive-interface default
network 192.168.1.0
network 1.1.1.0 0.0.0.255
!
line con 0
line aux 0
line vty 0 4
!
end

Router_B コンフィグ

hostname Router_B
!
interface Loopback1
ip address 2.2.2.2 255.255.255.0
!
interface GigabitEthernet0/0
ip address 192.168.1.2 255.255.255.0
!
router eigrp 1
passive-interface default
network 192.168.1.0
network 2.2.2.0 0.0.0.255
!
line con 0
line aux 0
line vty 0 4
!
end

本日の回答 :

正解は【D】になります。

EIGRPのトラブルシューティングで有効な「show ip eigrp neighbors, show ip eigrp interface」でEIGRPの状態を確認してもログには何も表記されないので、「debug eigrp packet」で確認してみると、どうやら「EIGRP : Hello receive/send」に問題が発生してるので、トラフィックフィルタが影響しているのが確認できます。下記のコンフィグレーションガイドを参考にEIGRPプロセスに「passive-interface default」がセットされているので、EIGRPを有効にしたい「interface Gi0/0」に対して「no passive-interface」を実施することで問題が解決されました。

passive-interface」って何?と思われた方も多いと思いますが、本来の目的はEIGRP/RIP/OSPFなどのルーティングプロトコルのパケットを送信しないようにしているインタフェースです。(今回はdefaultキーワードがあるので全てのI/FでEIGRP通信をブロックしていました!) また、このコマンドは商用ネットワークでよくみる「オマジナイ」のようなキーワードで、コンフィグ投入時に設定ミスで不要なアドレスがルーティング情報として流れるといけないので、デフォルトで全てのI/Fにフィルタをかけて、必要に応じて「no passive」コマンドで新規I/Fのルーティング情報のみ有効にする運用がよく取られています。(詳細は上記のConfiguratinon Guideも参照ください)

おすすめの書籍 :

Cisco人気ブログのご紹介 :

皆様からのご質問について

本サイトでは皆様からご質問を受け付けております。ご質問には必ずご回答させていただきますので、まずは本ブログサイトの”お問い合わせ“より、ご連絡をお願い致します。

Cisco
スポンサーリンク
♡(ˊo̴̶̷̤ ᴗ o̴̶̷̤ˋ)***シェアをお願い致します***(ˊo̴̶̷̤ ᴗ o̴̶̷̤ˋ)♡